选股指标 一阳穿多线且放量

kewou
460
文章
0
评论
2023年3月10日18:03:10 评论 458 views 979字阅读3分15秒
外汇返佣

选股需求:

1、一阳穿多线,上穿5、10、20、30、60
2、均线粘合,多头排列
3、上升趋势中
4、放量

通达信条件选代码

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
均线较大值:=MAX(MAX(MAX(MAX(MA5,MA10),MA20),MA30),MA60);{均线中最大值}
均线较小值:=MIN(MIN(MIN(MIN(MA5,MA10),MA20),MA30),MA60);{均线中最小值}
波动:=均线较大值/均线较小值<=1.04 AND C>均线较大值 AND O<均线较小值 AND V>REF(V,1)*1.7;
S1:DRAWTEXT(波动,L,'一阳穿多线'),COLORLIMAGENTA;{满足条件做标记};

选股指标 一阳穿多线且放量

指标代码:

MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA30:MA(C,30);
MA60:MA(C,60);
均线较大值:=MAX(MAX(MAX(MAX(MA5,MA10),MA20),MA30),MA60);{均线中最大值}
均线较小值:=MIN(MIN(MIN(MIN(MA5,MA10),MA20),MA30),MA60);{均线中最小值}
波动:=均线较大值/均线较小值<=1.04 AND C>均线较大值 AND O<均线较小值 AND V>REF(V,1)*1.7;
S1:DRAWTEXT(波动,L,'一阳穿多线'),COLORLIMAGENTA;{满足条件做标记};
S2: DRAWICON(波动,O,7);

动态测试结果:

输出MA5:收盘价的5日简单移动平均
输出MA10:收盘价的10日简单移动平均
输出MA20:收盘价的20日简单移动平均
输出MA30:收盘价的30日简单移动平均
输出MA60:收盘价的60日简单移动平均
均线较大值赋值:MA5和MA10的较大值和MA20的较大值和MA30的较大值和MA60的较大值
均线较小值赋值:MA5和MA10的较小值和MA20的较小值和MA30的较小值和MA60的较小值
波动赋值:均线较大值/均线较小值<=1.04 AND 收盘价>均线较大值 AND 开盘价<均线较小值 AND 成交量(手)>1日前的成交量(手)*1.7
输出S1:当满足条件波动时,在最低价位置书写文字,画淡洋红色

  • 合作微信
  • 商务合作联系微信
  • weinxin
  • 官方公众号
  • 我的微信公众号扫一扫
  • weinxin
  • 文本由 发表于 2023年3月10日18:03:10
  • 除非特殊声明,本站文章均为原创,转载请务必保留本文链接
通达信 560天均线自动选股指标 附源码 指标编程

通达信 560天均线自动选股指标 附源码

选股逻辑,强势突破60日均线后回撤的股票。筛选条件: 1、过去两天缩量。 2、5日均线在60日均线3%附近。 3、过去5日下跌天数大于3,过去7日下跌次数少于5。 4、换手率大于1%。 指标代码如下,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: